[Nitro] Component System instead of ClassMethods hack?

TRANS transfire at gmail.com
Mon Jun 12 11:16:42 EDT 2006

On 6/12/06, Jonas Pfenniger <zimba.tm at gmail.com> wrote:
> > Thoughts?
> Yes, please don't use Component it is a too generic term. I propose
> Aggregator since it's what it's doing. Il also goes well with the
> Delegator and Forwarder terms.

Is there a conflict with  the term 'Component' somewhere? Well, maybe
it is too generic, but I don't like Aggregator, it's far too tied up
with the concept of RSS these days. And I don't want to name it after
something it incidently "does", but rather what it represents, eg. a
synonym for 'Module'. Hmm... How about 'Capsule'?

> On the technical part, should X inheritors also inherit class methods
> ? I don't know if you handled that case.
> Eg.
> class Y < X; end
> Y.c #=> c

It does.

> Also, is this always a wanted feature or does it needs some control ?

That's beyond anyone's control but Matz', I'm afraid. (Well, there may
be some convoluted means of working something to that effect in, but I
don't think the very limited use case warrents all the nastiness.)


More information about the Nitro-general mailing list