[Nitro] Attempting to run Spark test/tc_controller.rb tests

Bill Kelly billk at cts.com
Wed Jun 7 20:00:47 EDT 2006


Hi,

I'm using nitro-0.30.0, and am attempting to learn how to
do TDD in Nitro.  I saw spark-1.2.0 has some tests, so I'm
trying to get them to run.

I was able to get Spark's test/tc_model.rb tests to run by
adding a "require 'cgi'" at the top of the file.

But the test/tc_controller.rb tests are failing with:

  NoMethodError: undefined method `controller' for
   #<TestWikiController:0x52aea2f0>
      test/tc_controller.rb:7:in `setup'

Failing on line 7:

06:  def setup
07:    controller WikiController
08:  end

I tried grepping Nitro's source for "def.*controller" but
only located one such method being defined, in 
lib/nitro/context.rb, and that controller method seems 
to be unrelated.

Kashia tried to help me on IRC, but:
[16:11] <Kashia> well, I get the same error as you, so it didn't
get fixed in the newest glycerin either :)


Thanks for any help.

Regards,

Bill





More information about the Nitro-general mailing list