[Nitro] [BUG] Mongrel + Pager

Jonas Pfenniger zimba.tm at gmail.com
Mon Jun 5 15:18:55 EDT 2006


The REQUEST_URI thing is wrong, I've made an adapter today and it did
work. I think the problem comes from the adapter that was just
copy-paster from the Webrick adapter.

On 05/06/06, Bryan Soto <bryan.a.soto at gmail.com> wrote:
> Hi Kashia,
>
> Just a quick note. I think this might be a Mongrel bug. I'm going to
> try out Zed's release candidate and see if it works there. If not,
> I'll run it by him and see. Basically, Mongrel is setting the
> REQUEST_URI header to '/' rather than the full uri like Apache,
> Webrick, etc.
>
> Bryan
>
> On 6/3/06, Jonathan Buch <john at oxyliquit.de> wrote:
> > Hi,
> >
> > I tried to move Oxyliquit to mongrel (because my virtual server is
> > acting up real strange) but I have a problem:
> >
> > The pager doesn't work anymore. The links are broken (they don't have
> > the domain it it, just the path). Might be the @request.uri ?
> > Not sure. I moved Oxywtf back to apache.
> >
> > Thank you William for reporting the problem with the Tutorials!
> >
> > I apologize for the instability of Oxywtf...
> > This vServer sucks donkey ass... I want a better one, should've taken
> > Hosteurope after all.... ;/
> >
> > Kashia
> >
> > --
> > Feel the love
> > http://pinkjuice.com/pics/ruby.png
> > _______________________________________________
> > Nitro-general mailing list
> > Nitro-general at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/nitro-general
> >
> _______________________________________________
> Nitro-general mailing list
> Nitro-general at rubyforge.org
> http://rubyforge.org/mailman/listinfo/nitro-general
>


-- 
Cheers,
  zimbatm

http://zimbatm.oree.ch



More information about the Nitro-general mailing list