[Nitro] newer postgres interface snapshots

Tim Howe timh at dirtymonday.net
Wed Jan 4 14:17:03 EST 2006

On Wed, 4 Jan 2006 19:09:45 +0000
rob <rob at motionpath.com> wrote:

> If nobody else looks into this I will do so later on in the month. I  
> am quite surprised at this as we have a number of applications that  
> have dates, boolean, etc with the psql store and one of my co-workers  
> was fairly recently using spark with PostgreSQL. Can this problem be  
> reproduced now simply by running Spark?

	Yes.  I even installed an entirely new Ruby installation, new gems, new Nitro 0.26, and new Spark 0.8.0.  I then installed the latest Pg interface snap, and got the same errors.  Then I installed the old Pg interface 0.7.1 release and everything worked fine.  Snapshots beginning in late November should start to see these problems.  Below is a quote from an email I got on Nov. 21st from Dave lee, the ruby postgres maintainer:

I just wanted to get the word out that I have been working on a new
release (0.8) and have created a couple snapshot releases over the
last few days.  There are some bug fixes, as well as new features such
as better connect methods (takes connection string or connection
hash), the exec and query methods now support optional bind parameters
(using postgresql native bind params, $1, $2, etc), the rows returned
by query are now a subclass of Array that provides hash-like features
(including indexing by column name and a to_hash method), and also the
data returned by queries is now converted to the appropriate ruby type
in the simple cases, like integers, floats, booleans, and bytea.


More information about the Nitro-general mailing list