[Nitro] [PATCH] Runner bugfix

Alexander Lazic al-nitrogen at none.at
Thu Aug 31 17:15:59 EDT 2006


Hi,

On Don 31.08.2006 18:26, George Moschovitis wrote:
>btw you can use:
>
>$nitro mongrel
>
>or
>
>$nitro --adapter mongrel
>
>or
>
>$nitro -a mongrel
>
>with the repo version.

I have get the repo at ~22:00 and have try to call nitro with this
options but i *always* get webrick:

What I have done:

darcs get http://repo.nitroproject.org/ repo
---run.rb
require 'rubygems'
require 'repo/glycerin'
require 'nitro'

class HelloController
  def index
    "Hello, World!"
  end
end

Nitro.run HelloController
---

ruby run.rb -m -D             ==> Listening at 0.0.0.0:9999. [WEBRICK]
ruby run.rb --adapter mongrel ==> Listening at 0.0.0.0:9999. [WEBRICK]
ruby run.rb -a mongrel          --- "" ----
ruby run.rb mongrel             --- "" ----

Sorry but with the current repo i can't call mongrel or some other
adapter:

ruby run.rb --scgi  ==> Listening at 0.0.0.0:9999. [WEBRICK]

Regards

Alex


More information about the Nitro-general mailing list