[Nitro] nitro from darcs and ruby gem

Alexander Lazic al-nitrogen at none.at
Thu Aug 31 04:13:09 EDT 2006


On Don 31.08.2006 11:09, Michael Fellinger wrote:
>On Thursday 31 August 2006 06:38, Alexander Lazic wrote:
>> today I got the current dev-code, thanks to Fabian for his help, now
>> i have try to run it but i have some errors :-(
>> What i have done:
>[long snip ... snap]
>i see several issues here :)
>you try to use gems along with the repo... but well, that is possible -
>i just found it redunant.

should i uninstall the nitro from gems?!

>another thing is, you use facets 1.7.30 - nitro still runs on 1.4.5 and
>no idea when some wizard will get it running on the new facets... there
>are always odd things that i have no idea of how they should work and
>when they break i have even less ideas of how or why or where they
>broke... (we should work on that *hint hint*)

Ok i have remove all except 1.4.5.

>next thing - you copy nitro to the gems-dir?

>it's not going to work unless you'd copy glue/gen/og as well... and to
>avoid all that hassle there is a simpler way there is a file named
>'glycerin.rb' within the repo-root, and require
>'your/path/to/repo/glycerin' will modify your path and sneak in the
>repo-paths, so that you can just use require 'nitro' afterwards.

I have thought that a 'mv nitro' could be all, that was the reason why I
have asked ;-)

>ok, now a summary for everybody to write down :)


>darcs get http://repo.nitroproject.org/ repo
># this as su or maybe via sudo... ( hope i didn't forget anything )
>gem install facets --version=1.4.5
>gem install ruby-breakpoint RedCloth mongrel daemons -y


>ok, that's it. To get a simple test, try
>wget -O run.rb http://pastie.caboo.se/10995/download
>and then issue the simple
>ruby run.rb

Also done but I can't run it with mongrel :-(

ruby -d run.rb -m -D > run.out 2>&1

. many many warnings from facets-1.4.5
[2006-08-31 10:02:27] INFO  WEBrick 1.<3.1

You can get the full output from http://none.at/run.out

Here the current installed gems:

gem list --local|egrep '^[a-zA-Z]'
daemons (1.0.1, 0.4.4)
facets (1.4.5)
gem_plugin (0.2.1)
gen (0.31.0)
glue (0.31.0)
mongrel (
mongrel_cluster (0.2.0)
nitro (0.31.0)
og (0.31.0)
rake (0.7.1)
RedCloth (3.0.4, 3.0.3)
ruby-breakpoint (0.5.1)
rubygems-update (0.9.0)
sources (0.0.1)
sqlite3-ruby (1.1.0)

>hope this made clearer how to use the repo :)

Yep super thanks for your explanation ;-)))

>for questions, just mail (or rather, ask on irc, freenode #nitro)

I will try to contact the irc at the early afternoon, thanks again for
your help.



More information about the Nitro-general mailing list