[Nitro] Rolls sounds interesting

TRANS transfire at gmail.com
Fri Aug 4 11:04:13 EDT 2006


On 8/4/06, Fabian Buch <fabian at oggu.de> wrote:
>
> Am 04.08.2006 um 14:53 schrieb TRANS:
> > On 8/4/06, Fabian Buch <fabian at oggu.de> wrote:
> >> Would the developer usually put a fruitapp.rb at the highest level to
> >> require the current version and each time installing a new version
> >> would override this fruitapp.rb? What if someone installs an older
> >> version of a lib after he installed the latest version?
> >
> > Yes, that can be a problem if the older version is functionally
> > different from the latest version. Top level files should really
> > contian nothing more then requires to a subdir. In fact, Rolls makes
>
> That's what I had in mind "just a require", but if it's versiond (no
> rolls installed), it'd contain "require 'fruitapp/1.0/x.rb'" and when
> installing the next version the fruitapp.rb would be replaced by a
> file containing "require 'fruitapp/1.1/x.rb'", which is usually fine,
> but if the user afterwards installs version 0.6 it'll again be
> replaced by a file containing "require 'fruitapp/0.6/x.rb'". This
> might not happen often, but the user will probably look for hours why
> a functionality he expects from fruitapp version 1.1 isn't working,
> since he thinks he installed the latest version (which is installed
> in fact).

Not so sure about this. The fruitapp.rb file should only contain
"require 'frutiapp/x.rb'" --no version reference. In which case if
Rolls is installed then the versioned and non-versioned will work. If
Rolls is not installed then only the non-versioned will work.

The problem I was thinking of is along the lines of installing an
older version of a lib built prior to any notion of Rolls, along side
one that is rolled. That has some potential for file conflicts.

T.


More information about the Nitro-general mailing list