[Nitro] Rolls sounds interesting

Fabian Buch fabian at oggu.de
Fri Aug 4 05:24:38 EDT 2006


hey Trans,

http://roll.rubyforge.org/overview.html sounds very interesting.

One question: has Rolls to be installed on a users system to require  
a versioned lib? (not for installing, I mean requireing, e.g. if the  
user just unpacked the package using tar or similar)

Considering the following directory structure:

     fruitapp/
       1.0.0/
         fruit/
           apple.rb
         basket/
           wicker.rb

Now the user does:

   require 'fruitapp'

Would the developer usually put a fruitapp.rb at the highest level to  
require the current version and each time installing a new version  
would override this fruitapp.rb? What if someone installs an older  
version of a lib after he installed the latest version?

Fabian


-- 
Nitro Q&A: http://oxyliquit.de/
Blog: http://blog.fabian-buch.de





More information about the Nitro-general mailing list