[Nitro] problem with: facets-1.3.2-update and Tags

john at oxyliquit.de john at oxyliquit.de
Thu Apr 27 04:53:28 EDT 2006


Hi Bryan,
 
This patch:
 
Tue Apr 25 07:46:29 CEST 2006  bryan.a.soto at gmail.com
  * facets-1.3.2-update
  Updates to facets 1.3.2 by removing the Glue namespace prefix from Nitro code.
 
This seems to do more stuff than just removing prefixes.
 
I had conflicts in psql.rb and sql.rb
 
after resolving them and starting:
 
E, [2006-04-26T13:55:31.672604 #6653] ERROR -- : Error while handling '/'.
E, [2006-04-26T13:55:31.674394 #6653] ERROR -- : undefined method `getvalue' for #<Array:0x21145d4>
  (eval):4:in `og_read'
  /Volumes/Data/build/cvs/nitro/og/lib/og/store/sql.rb:1177:in `read_all'
  /Volumes/Data/build/cvs/nitro/og/lib/og/store/psql.rb:139:in `each_row'
  /Volumes/Data/build/cvs/nitro/og/lib/og/store/psql.rb:138:in `each_row'
  /Volumes/Data/build/cvs/nitro/og/lib/og/store/sql.rb:1175:in `read_all'
  /Volumes/Data/build/cvs/nitro/og/lib/og/store/sql.rb:470:in `find'
  /Volumes/Data/build/cvs/nitro/og/lib/og/entity.rb:191:in `find'
  ./src/controller.rb:21:in `index'
  (eval):6:in `index_action'
  /Volumes/Data/build/cvs/nitro/nitro/lib/nitro/controller.rb:93:in `method_missing'
  /Volumes/Data/build/cvs/nitro/nitro/lib/nitro/render.rb:129:in `render'
  /Volumes/Data/build/cvs/nitro/nitro/lib/nitro/adapter/webrick.rb:223:in `do_GET'
  /usr/local/lib/ruby/1.8/webrick/httpservlet/abstract.rb:35:in `service'
  /usr/local/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
  /usr/local/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
  /usr/local/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
  /usr/local/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
  /usr/local/lib/ruby/1.8/webrick/server.rb:95:in `start'
  /usr/local/lib/ruby/1.8/webrick/server.rb:92:in `start'
  /usr/local/lib/ruby/1.8/webrick/server.rb:23:in `start'
  /usr/local/lib/ruby/1.8/webrick/server.rb:82:in `start'
  /Volumes/Data/build/cvs/nitro/nitro/lib/nitro/adapter/webrick.rb:59:in `start'
  /Volumes/Data/build/cvs/nitro/nitro/lib/nitro/server/runner.rb:344:in `invoke_server'
  /Volumes/Data/build/cvs/nitro/nitro/lib/nitro/server/runner.rb:306:in `invoke'
  /Volumes/Data/build/cvs/nitro/nitro/lib/nitro/server.rb:128:in `run'
  /Volumes/Data/build/cvs/nitro/nitro/lib/nitro.rb:78:in `run'
  ./run.rb:96
  LOGGED FROM: /Volumes/Data/build/cvs/nitro/nitro/lib/nitro/render.rb:249:in `log_error'
D, [2006-04-26T13:55:31.701004 #6653] DEBUG -- : Rendering '/error'.
 
I either seem to have a non standard patch (maybe psql refactoring from bsoto?),
or something else is breaking.
 
Don't know what's causing the issue.. I unpulled it for now.
 
And another thing while I'm ranting: why removing the Tag from Glue again? -_-
We agreed at the time, that having "Tag" in the global namespace isn't exactly
a good idea. And moving something _temporarily_ is an even worse idea, right
now I'm just not pulling that patch from George, I'm just waiting for it to
move to Nitro or Og or something.
 
Kashia
 
--
Feel the love
http://pinkjuice.com/pics/ruby.png



More information about the Nitro-general mailing list