[Nitro] [PATCH] og-psql-refactoring

Bryan Soto bryan.a.soto at gmail.com
Sun Apr 9 14:24:43 EDT 2006


On 4/9/06, TRANS <transfire at gmail.com> wrote:
> On 4/9/06, Bryan Soto <bryan.a.soto at gmail.com> wrote:
> > On 4/9/06, TRANS <transfire at gmail.com> wrote:
> > > Hi Bryan,
> > >
> > > I tried running the test suite myself and get this:
> > >
> > > .dropdb: database removal failed: ERROR:  database "test" does not exist
> > > dropdb: database removal failed: ERROR:  database "test" does not exist
> > > .dropdb: database removal failed: ERROR:  database "test" does not exist
> > > dropdb: database removal failed: ERROR:  database "test" does not exist
> > > ./test/og/tc_delete_all.rb:26: undefined method `manage_classes' for
> > > nil:NilClass (NoMethodError)
> > >         from -:14
> > >
> >
> > In the checked out repo, there is a file, og\test\og\CONFIG.rb that
> > needs to be edited with your connection settings, username, password,
> > etc.
> >
> > Perhaps that's the problem?
>
> Nah, I wrote CONFIG.rb ;-)  Although, its' a bit hackish --certainly
> could use come improvements, the problem is Og.setup is returning nil
> for some reason. What would cause Og.setup to return nil, rather that
> raise an error? That seems odd.
>

That's right. I forgot your name was in there...

Hmm... Well, you could try setting debug to true, though I'm guessing
it's all those errors about test not existing that's causing your
problem. Does it work for other stores? Perhaps postgres needs to have
the db created manually the first time around?

--
"Never tell people how to do things. Tell them what to do and they
will surprise you with their ingenuity." —General George S. Patton




More information about the Nitro-general mailing list