[Nitro] Gem dependencies.

James Britt james_b at neurogami.com
Wed Apr 5 18:52:35 EDT 2006


TRANS wrote:
> On 4/5/06, TRANS <transfire at gmail.com> wrote:
> 
>>>facets, '~> 1.2'     # This assumes that anything that changes
>>>interface will be 2.0+
>>
>>Hmm... it's not up to 1.3+? Well if not then I think make it
>>
>>  facets, '~> 1.2.0'
>>
>>Tell me if you think I've misjudged on this, but my reasoning is that
>>Facets has so many libs that any _one_ interface change in any _one_
>>of them requires a version jump and I don't want to be pushing version
>>5.0+ just b/c of four such changes.
> 
> 
> Okay, there's two side to this coin. You want to loosen the constraint
> on Nitro's dependencies to allows Facets or other dependency to be
> updated and Nitro use the latest. Well, it's a tow edge sword. You may
> run into some issures now to make sure Nitro is picking up the right
> version, but you could also run into trouble later if something
> changes that effects Nitro adversely.
> 
> Personally I lean towards George's opinion. Keep strict version control.


That can work, but I think then the gem packaging may need some 
tightening up, because gen, for example, didn't force the installation 
of a specific facets gem, but it (or something in it's requirement 
chain) would complain when I ran it.


-- 
James Britt

http://www.ruby-doc.org       - Ruby Help & Documentation
http://www.artima.com/rubycs/ - The Journal By & For Rubyists
http://www.rubystuff.com      - The Ruby Store for Ruby Stuff
http://www.jamesbritt.com     - Playing with Better Toys
http://www.30secondrule.com   - Building Better Tools



More information about the Nitro-general mailing list