[Nitro] Gem dependencies.

Bryan Soto bryan.a.soto at gmail.com
Wed Apr 5 14:23:08 EDT 2006

On 4/5/06, TRANS <transfire at gmail.com> wrote:
> On 4/5/06, TRANS <transfire at gmail.com> wrote:
> > > facets, '~> 1.2'     # This assumes that anything that changes
> > > interface will be 2.0+
> >
> > Hmm... it's not up to 1.3+? Well if not then I think make it
> >
> >   facets, '~> 1.2.0'
> >
> > Tell me if you think I've misjudged on this, but my reasoning is that
> > Facets has so many libs that any _one_ interface change in any _one_
> > of them requires a version jump and I don't want to be pushing version
> > 5.0+ just b/c of four such changes.
> Okay, there's two side to this coin. You want to loosen the constraint
> on Nitro's dependencies to allows Facets or other dependency to be
> updated and Nitro use the latest. Well, it's a tow edge sword. You may
> run into some issures now to make sure Nitro is picking up the right
> version, but you could also run into trouble later if something
> changes that effects Nitro adversely.

In which case, we release new gems of our own to accomodate. Besides,
George loves to "release early and release often". And if he's not
available, I have access to the Rubyforge file release. I don't know
how to use it, but I'm sure someone would be able to help me if I
needed it. :)

> Personally I lean towards George's opinion. Keep strict version control.

But then people aren't able to use the latest facet in their Nitro or
Og apps without getting those pesky gem activation errors. There's the

"Never tell people how to do things. Tell them what to do and they
will surprise you with their ingenuity." —General George S. Patton

More information about the Nitro-general mailing list