[Nitro] Gem dependencies.

TRANS transfire at gmail.com
Wed Apr 5 13:32:41 EDT 2006

On 4/5/06, TRANS <transfire at gmail.com> wrote:
> > facets, '~> 1.2'     # This assumes that anything that changes
> > interface will be 2.0+
> Hmm... it's not up to 1.3+? Well if not then I think make it
>   facets, '~> 1.2.0'
> Tell me if you think I've misjudged on this, but my reasoning is that
> Facets has so many libs that any _one_ interface change in any _one_
> of them requires a version jump and I don't want to be pushing version
> 5.0+ just b/c of four such changes.

Okay, there's two side to this coin. You want to loosen the constraint
on Nitro's dependencies to allows Facets or other dependency to be
updated and Nitro use the latest. Well, it's a tow edge sword. You may
run into some issures now to make sure Nitro is picking up the right
version, but you could also run into trouble later if something
changes that effects Nitro adversely.

Personally I lean towards George's opinion. Keep strict version control.


More information about the Nitro-general mailing list