[Nitro] Gem dependencies.

Dimitri Aivaliotis aglarond at gmail.com
Wed Apr 5 03:29:45 EDT 2006


On 4/5/06, Bryan Soto <bryan.a.soto at gmail.com> wrote:
>
> So, in Ruby Gem constraint language:
> facets, '~> 1.2'     # This assumes that anything that changes
> interface will be 2.0+
> RedCloth, '= 3.0.3'   # Assuming 3.0.4 is buggy
> daemons, '~> 0.4'    # All the recent updates have been bug fixes
> ruby-breakpoint, '~> 0.5'     # This one hasn't changed in over a year, but...
>
> The ~> tells gems that the releases should be backwards compatible. As
> an example, if the interface for facets changed in a way that broke
> old code, it expects the version number would bump to 2.0. As long as
> the code is backwards compatible all the way up to 2.0, this should
> prevent the errors James and others have reported in regards to
> facets.
>
> Comments?

Sounds good to me.  Can this be done for 0.30.0?

- Dimitri




More information about the Nitro-general mailing list