[Nitro] Gem dependencies.

Bryan Soto bryan.a.soto at gmail.com
Wed Apr 5 01:32:49 EDT 2006


Following up on James' complaint and Trans' comments re: gem
installation noise, perhaps we should revamp our dependencies. So our
correct dependencies are:

Glue: Facets RedCloth

Og: Glue

Nitro: Gen Og Ruby-Breakpoint Daemons

Gen: Nitro

Somewhat cleaned up to try and eliminate the double glue install. I
know we we're going to try and get rid of glue, but according to my
chat log, George is looking to release this week, so I'm thinking we
should delay that till after this release.

Of these, what do we really need?

In addition, to end our Ruby gem versioning problem, perhaps we should
get away from exact requirements. Well, possibly excepting RedCloth.
I've heard that 3.0.4 is buggy.

So, in Ruby Gem constraint language:
facets, '~> 1.2'     # This assumes that anything that changes
interface will be 2.0+
RedCloth, '= 3.0.3'   # Assuming 3.0.4 is buggy
daemons, '~> 0.4'    # All the recent updates have been bug fixes
ruby-breakpoint, '~> 0.5'     # This one hasn't changed in over a year, but...

The ~> tells gems that the releases should be backwards compatible. As
an example, if the interface for facets changed in a way that broke
old code, it expects the version number would bump to 2.0. As long as
the code is backwards compatible all the way up to 2.0, this should
prevent the errors James and others have reported in regards to
facets.

Comments?

--
"Never tell people how to do things. Tell them what to do and they
will surprise you with their ingenuity." —General George S. Patton




More information about the Nitro-general mailing list