[Nitro] gen - facet rubygems version hell

James Britt james_b at neurogami.com
Mon Apr 3 22:03:28 EDT 2006

I just tried to create a Nitro app using gen, and got this:

`report_activate_error': RubyGem version error: facets(1.2.1 not = 
1.0.3) (Gem::LoadError)


Not too long ago I was running something else and had dopey gem version 
noise regarding facets; I forget the details, but I noticed that the 
names and numbering of facets were inconsistent (some had obvious 
version numbers, others had what looked like dates).

I cleared out facets, and installed  the latest version fresh.

Apparently, though, the gen installed with Nitro 0.29 does not care for 
the latest facets, insisting on a very specific version.

OK, so I uninstall all gen gems, and reinstall, figuring it will also 
install the dependencies.

Nope.  It seems (I haven't looked) that the code demands a special 
version, but the gem spec does nothing to enforce this.  Very bad.

I also tried reinstall Nitro, figuring it would makes sure I had working 
arrangement of gen  and facets.


Now, I may have botched my set up someplace along the lines, but this is 
not the first time I've had issues with *exact* gem versions were needed 
for some part of Nitro, and code would not run.

I believe that it is a bad idea to write a library that requires a fixed 
version, rather than some version or better, of another library. 
Otherwise it is too fragile and you get these problems.

I certainly hope this gets sorted out soon.  If libraries are so 
unstable, then should not be in gems; they should be directly bundled 
with the main distribution.  Gem paths and file names should not be 
bouncing around from one version to the next.

I'm wondering if all the code needed for Og/Nitro should just be package 
up into one gem, until Nitro reached version 1.0.  And the the code can 
be refactored into subsections.

Anyway, rant over; I'm going to finish dinner.

James Britt

"Blanket statements are over-rated"

More information about the Nitro-general mailing list