[Nitro] properties

TRANS transfire at gmail.com
Sun Apr 2 13:35:55 EDT 2006

On 4/2/06, Bryan Soto <bryan.a.soto at gmail.com> wrote:
> Just a thought. So we're back to the previous discussion of tracking
> down a good name.
> First, the exact problem is that every property defined in an Og model
> is stored in a hash that is accessed by using the name "properties".
> So strewn throughout the Glue and Og code are numerous calls to
> properties. Properties is also used by GTK to access the internal
> properties of a GLib object, so we are both using the same name and,
> depending on the order of require, one is replacing the other causing
> no end of headaches. The collision is that both Og and GTK are using
> "properties" internally.
> This is what's been suggested so far:
> graph_properties
> class_properties
> facet_properties
> facets
> Any other suggestions?

I'm starting to lean toward the idea that was suggested earlier. Why
do we just use modified forms of the attr_ methods? As long as their
backward compatible, what does it really matter?


More information about the Nitro-general mailing list