[Nitro] Og psql broken? -- RESOLVED

Reid Thompson Reid.Thompson at ateb.com
Fri Sep 30 11:19:03 EDT 2005


Reid Thompson wrote:
> WinXP cygwin
> 
> anyone else having issues like this ..
> this was working before...
> complains of not finding a file that exists....
> 
> WS-XP-4960: /home/rthompso>
> $ ll /lib/ruby/gems/1.8/gems/postgres-0.7.1/./postgres.so
> -rwx------+ 1 Reid.Thompson Domain Users 27648 Feb 28  2005
> /lib/ruby/gems/1.8/gems/postgres-0.7.1/./postgres.so*
> 
> WS-XP-4960: /home/rthompso>
> $ ruby -rubygems ogtest.rb
> ERROR: Ruby-PostgreSQL bindings are not installed!
> ERROR: No such file or directory -
> /lib/ruby/gems/1.8/gems/postgres-0.7.1/./postgres.so
> (LoadError) /lib/ruby/gems/1.8/gems/postgres-0.7.1/./postgres.so
> /lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> `require' /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og/store/psql.rb:2
> /lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in `require__'
> /lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> `require' (eval):2:in `for_name'
> /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og/manager.rb:45:in `eval'
> /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og/store.rb:24:in `for_name'
> /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og/manager.rb:45:in `initialize'
> /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og.rb:118:in `new'
/lib/ruby/gems/1.8/gems/og-> 0.23.0/lib/og.rb:118:in `setup'
ogtest.rb:22 
> /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og/store.rb:24:in `for_name':
> /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og/store/psql.rb:34:in
> `alias_method': undefined method `clear' for class `PGresult'
>         (NameError) from
>         /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og/store/psql.rb:34
>         from
>         /lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
>         `require__' from
>         /lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
>         `require' from (eval):2:in `for_name' from
>         /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og/manager.rb:45:in
> `eval' from /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og/store.rb:24:in
> `for_name' from
> /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og/manager.rb:45:in
> `initialize' from /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og.rb:118:in
> `new'         from /lib/ruby/gems/1.8/gems/og-0.23.0/lib/og.rb:118:in
> `setup'         from ogtest.rb:22 WS-XP-4960: /home/rthompso>    
> 
> _______________________________________________
> Nitro-general mailing list
> Nitro-general at rubyforge.org
> http://rubyforge.org/mailman/listinf> o/nitro-general

resolved -- rebuilding the gem fixed the problem -- 

reid




More information about the Nitro-general mailing list