[Nitro] nitrogen / nitro: uninitialized constant

Bryan Soto bryan.soto at sgvn.com
Tue Sep 27 14:10:35 EDT 2005


Hi Tim,

I had the same problem after upgrading to nano-0.9.2.

gem uninstall nano
gem install nano --version=0.8.2

was what I used. I note your using locally installed gems, so you'll 
might have to modify the install accordingly.

Hope that helps,
Bryan

Tim Koenig wrote:
> Hi,
> 
> I've tried to install Nitro and have been running into problems almost
> immediately :-|. Since everybody else seems to have no problem running
> it, it's almost certainly a problem on my part - I'm out of guesses
> now, though :-(.
> 
> This is what I get after invoking 'nitrogen':
> /home/tim/soft/ruby/gems/gems/og-0.23.0/lib/og/entity.rb:70:in
> `append_features': uninitialized constant
> Og::EntityMixin::RelationMacros (NameError)
>         from /home/tim/soft/ruby/gems/gems/og-0.23.0/lib/og/entity.rb:224
> [...]
> 
> The same behaviour appears when using three different
> ruby-installations (1.8.3 on Debian/Sid, 1.8.2 on Debian/Sarge, 1.8.2
> on Win32). I'm using locally installed gems (in my home directory,
> other gems work flawlessly, and the One-Click Ruby installer's version
> on Win32).
> 
> Any guesses? Is this a FAQ (couldn't find anyone mentioning it on the
> mailing list, though)?
> 
> Thanks,
> Tim
> 
> _______________________________________________
> Nitro-general mailing list
> Nitro-general at rubyforge.org
> http://rubyforge.org/mailman/listinfo/nitro-general
> 
> 




More information about the Nitro-general mailing list