[Nitro] deadlock ?? (webrick, nitro and nano)

manveru ulmo at valaraan.de
Sat Sep 3 16:48:25 EDT 2005

manveru wrote:

> Hi list,
> i've just extended spark (0.5) with the rdog-stuff, and get these 
> lines everytime i load a page (page gets to the browser, but webrick 
> dies painful in the background
> ---------------------
> DEBUG: Rendering '/doc/core/Array'.
> DEBUG: Compiling action 'DocController#core'
> deadlock 0x40aa9fdc: run:-  - (null):0
> deadlock 0x40b3b4f0: sleep:T(1125772343.078191)  - 
> /usr/lib/ruby/gems/1.8/gems/nano-0.8.2/lib/nano/kernel/autoreload.rb:15
> deadlock 0x402f2748: sleep:ST(1125772342.577432) (main) - 
> /usr/lib/ruby/1.8/webrick/server.rb:91
> deadlock 0x40b32490: sleep:T(1125772371.313616)  - 
> /usr/lib/ruby/1.8/timeout.rb:42
> ----------------------------
> after he spits out these lines, no strg+c of the world gives me back 
> my shell, i have to 'killall ruby'...
> any idea what this is?
> i suppose some overload because of incompatibility between nano and 
> webrick, but i'm not sure... it just doesn't make any sense to me.
> maybe someone who knows webrick better could help?
> i'm not sure if the problem is solved by running it on apache... have 
> to get ruby running on it first.
> so long...
> manveru
> _______________________________________________
> Nitro-general mailing list
> Nitro-general at rubyforge.org
> http://rubyforge.org/mailman/listinfo/nitro-general
i tried that in a fresh and clean version of spark, i changed only the 
Og.setup in the run.rb to this:
# :destroy => true,
  :store => :sqlite,
  :name => 'spark',
  :user => 'root',
  :password => 'navelrulez'

hope it helps to track down the problem...
i remember ysabel said something about sqlite not fully supported or 
but as it is, i rely on it, or on the filesys - but that is official 

More information about the Nitro-general mailing list