[Nitro] Nitro and Facets version

Michael Kohl citizen428 at gentoo.org
Sun Oct 30 12:31:11 EST 2005

Hi all!

When I try to use nitrogen (which now seems to be called nitrogen.old),
it bails out complaining that the version of facets I use is not the
Nitro expects. 

/usr/lib/ruby/site_ruby/1.8/rubygems.rb:194:in `report_activate_error':
RubyGem version error: facets(2005.10.30 not = 2005.10.15)
(Gem::LoadError) from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:136:in
`activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:162:in
`activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:161:in
`activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:162:in
`activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:161:in
`activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:162:in
`activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:161:in
`activate' from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:37:in
from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:31:in `require_gem'
from /usr/bin/nitrogen.old:17

I now wonder if it's really necessary that $installed_version
== $expected_version or if $installed_version >= $expected_version
would make more sense.

I'm also curious if there's a new way we should use to generate new
apps? In his announcement mail George mentioned a new generation
framework, but I seem to be unable to find any more info on this. Sorry
if that's a dumb question, but I'm a little low on time currently, and
I try to get this ebuilds ready for submission...


web at citizen428.net                                 citizen428 at gentoo.org
http://citizen428.net/                http://dev.gentoo.org/~citizen428/
GnuPG key: 0x90CA09E3/4D21 916E DBCE 72B8 CDC5  BD87 DE2D 91A2 90CA 09E3
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://rubyforge.org/pipermail/nitro-general/attachments/20051030/a6a648d7/attachment.bin 

More information about the Nitro-general mailing list