[Nitro] class CgiUtils missing?

Fabian Buch fabian at oggu.de
Sat Oct 29 16:48:59 EDT 2005


Am 29.10.2005 um 20:59 schrieb George Moschovitis:

>> Anyway, thanks that you'll have a look into the CGI adapter.
>
> If you rename CgiUtils tou Cgi in adapter/cgi.rb it will work!

Okay, did that. Now I get the following:

[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147]  
/usr/lib/ruby/gems/1.8/gems/nitro-0.24.0/lib/nitro/cgi.rb:24:in  
`process'
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147] :
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147] undefined  
method `env' for #<CGI:0x40661d2c>
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147]  (
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147]  
NoMethodError
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147] )
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147] \tfrom  
/usr/lib/ruby/gems/1.8/gems/nitro-0.24.0/lib/nitro/adapter/cgi.rb:18:in  
`start'
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147] \tfrom  
/usr/lib/ruby/gems/1.8/gems/nitro-0.24.0/lib/nitro/server/runner.rb: 
242:in `invoke'
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147] \tfrom  
/usr/lib/ruby/gems/1.8/gems/nitro-0.24.0/lib/nitro/server.rb:123:in  
`run'
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147] \tfrom  
/usr/lib/ruby/gems/1.8/gems/nitro-0.24.0/lib/nitro.rb:65:in `run'
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147] \tfrom  
/home/david/devblog/public/../run.rb:39
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147] \tfrom  
/home/david/devblog/public/cgi.rb:5:in `require'
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147] \tfrom  
/home/david/devblog/public/cgi.rb:5
[Sat Oct 29 22:36:27 2005] [error] [client 162.162.236.147] Premature  
end of script headers: cgi.rb

Fabian Buch




More information about the Nitro-general mailing list