[Nitro] Install issues with 0.25

TimH timh at dirtymonday.net
Sat Nov 19 13:05:14 EST 2005


This was my first attempt at installing Nitro, so I have to admit to complete ignorance.  However, things that were confusing me last night also confused several people in #nitro and #ruby-lang.  These people helped me work out the issues, and I think some patches will be coming soon from one of them, but in the meantime this info may help others.

First of all nano and mega are no longer seperate packages; they are part of facets.  I don't know how interesting this info is since I had never heard of any of them.  Facets looks cool however and I may use it for some other stuff, but I digress..

After installing all the nitro, og, facets, glue, etc...  I tried to install and run Flare, but got the following error:
/usr/local/lib/ruby/site_ruby/1.8/nitro/scaffold.rb:32:in `read': No such file or directory - /usr/local/lib/ruby/site_ruby/1.8/../proto/public/scaffold/form.xhtml (Errno::ENOENT)
        from /usr/local/lib/ruby/site_ruby/1.8/nitro/scaffold.rb:32:in `compile_scaffold_action'
        from /usr/local/lib/ruby/site_ruby/1.8/nitro/scaffold.rb:93:in `scaffold'
        from ./src/controller/scaffold.rb:7
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in `require'
        from run.rb:11

This was fixed by manually copying the proto dir from the nitro distribution to /usr/local/lib/ruby/site_ruby/.

Then I tried to run Flare and got the following error:
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in `require__': no such file to load -- part/admin (LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in `require'
        from run.rb:16

This was fixed by manually copying src/part from the nitro distribution to /usr/local/lib/ruby/site_ruby/

Yen via sano
--TimH



More information about the Nitro-general mailing list