[Nitro] Trouble installing new Nitro gem

Rob Pitt rob at motionpath.com
Fri Nov 18 05:10:40 EST 2005


I had no problems when I used ruby on XP the other day. I would 
recommend you try an OS more friendly to coders with better tools like 
KDE/Linux (or if your rich, OS X).

Back to the problem in hand, you should be able to work around this by 
downloading the daemons gem file by hand and then running gem install on 
the file.


James Britt wrote:

>I just tried to update my copy of Nitro on my WinXP machine, and had 
>these results:
>
>
>d:\development>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" update nitro
>Upgrading installed gems...
>Attempting remote upgrade of nitro
>Attempting remote installation of 'nitro'
>Install required dependency gen? [Yn]  Y
>Install required dependency daemons? [Yn]  Y
>ERROR:  While executing gem ... (OpenURI::HTTPError)
>     300 Multiple Choices
>
>d:\development>
>
>
>Has anyone else seen this, or had gem installation issues?
>
>I'm using the "1-click" Windows isntaller of Ruby 1.8.2, and gems 0.8.10.
>
>
>James
>
>  
>




More information about the Nitro-general mailing list