[Nitro] CGI still broken in 0.25?

Rob Pitt rob at motionpath.com
Fri Nov 18 05:08:35 EST 2005


Under apache with the fast cgi adapter.

James Britt wrote:

>I just tried to run an app created with with 0.23 or 0.24, with the 
>Nitro 0.25 update installed.  I get the now-familiar message:
>
>#<NoMethodError: undefined method `env' for #<CGI:0x3f89e08>>
>
>
>I take it, then, that 0.25 is still CGI-crippled?
>
>How are people running their Nitro apps?  My next choice would be SCGI 
>under Apache2, or perhaps fcgi with lighttpd (if I could figure out how 
>to have multiple virtual hosts), but it seems all of these would depend 
>on CGI working correctly.
>
>
>
>Thanks,
>
>James
>
>  
>




More information about the Nitro-general mailing list