[Nitro] CGI still broken in 0.25?

James Britt james_b at neurogami.com
Thu Nov 17 12:18:38 EST 2005


I just tried to run an app created with with 0.23 or 0.24, with the 
Nitro 0.25 update installed.  I get the now-familiar message:

#<NoMethodError: undefined method `env' for #<CGI:0x3f89e08>>


I take it, then, that 0.25 is still CGI-crippled?

How are people running their Nitro apps?  My next choice would be SCGI 
under Apache2, or perhaps fcgi with lighttpd (if I could figure out how 
to have multiple virtual hosts), but it seems all of these would depend 
on CGI working correctly.



Thanks,

James

-- 

http://www.ruby-doc.org       - Ruby Help & Documentation
http://www.artima.com/rubycs/ - Ruby Code & Style: Writers wanted
http://www.rubystuff.com      - The Ruby Store for Ruby Stuff
http://www.jamesbritt.com     - Playing with Better Toys
http://www.30secondrule.com   - Building Better Tools



More information about the Nitro-general mailing list