[Nitro] examples-0.26: blog example doesn't work

Alexandre Gravem vikingtux at gmail.com
Sun Dec 25 01:08:00 EST 2005


I have experienced that error too when posting comments!

On 12/21/05, Jos Backus <jos at catnook.com> wrote:
>
> On Wed, Dec 21, 2005 at 04:23:12PM -0800, Bryan Soto wrote:
> > Hi,
> >
> > I ran into similar error messages, though on Linux. I believe it has to
> do
> > with the version of MySql and the Ruby bindings to it. You might try
> > running:
> >
> > gem install mysql
> >
> > to get the C bindings. Those worked for me. They're also faster.
> >
> > They might be available via ports, though I don't know for sure.
>
> I installed the gem and that seems to work. Thanks!
>
> My next problem occurs when I try to add a comment. Log:
>
> E, [2005-12-21T17:32:04.107682 #89161] ERROR -- : Error while handling
> '/view/2'.
> E, [2005-12-21T17:32:04.108430 #89161] ERROR -- : undefined method
> `create_time' for nil:NilClass
>   src/template/view.xhtml:30:in `view_template'
>   (eval):6:in `view_action'
>   /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/controller.rb:88:in
> `send'
>   /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/controller.rb:88:in
> `method_missing'
>   /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/render.rb:125:in
> `send'
>   /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/render.rb:125:in
> `render'
>   /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/adapter/webrick.rb:145:in
> `do_GET'
>   /usr/local/lib/ruby/1.8/webrick/httpservlet/abstract.rb:35:in `__send__'
>   /usr/local/lib/ruby/1.8/webrick/httpservlet/abstract.rb:35:in `service'
>   /usr/local/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
>   /usr/local/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
>   /usr/local/lib/ruby/1.8/webrick/server.rb:155:in `start_thread'
>   /usr/local/lib/ruby/1.8/webrick/server.rb:144:in `start'
>   /usr/local/lib/ruby/1.8/webrick/server.rb:144:in `start_thread'
>   /usr/local/lib/ruby/1.8/webrick/server.rb:94:in `start'
>   /usr/local/lib/ruby/1.8/webrick/server.rb:89:in `each'
>   /usr/local/lib/ruby/1.8/webrick/server.rb:89:in `start'
>   /usr/local/lib/ruby/1.8/webrick/server.rb:79:in `start'
>   /usr/local/lib/ruby/1.8/webrick/server.rb:79:in `start'
>   /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/adapter/webrick.rb:55:in
> `start'
>   /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/server/runner.rb:297:in
> `invoke_server'
>   /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/server/runner.rb:263:in
> `invoke'
>   /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/server.rb:124:in
> `run'
>   /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro.rb:73:in `run'
>   run.rb:48
>
> Do you see this too?
>
> --
> Jos Backus
> jos at catnook.com
> _______________________________________________
> Nitro-general mailing list
> Nitro-general at rubyforge.org
> http://rubyforge.org/mailman/listinfo/nitro-general
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/nitro-general/attachments/20051225/3069e994/attachment.html 


More information about the Nitro-general mailing list