[Nitro] Problem with Nitro In Flames tutorial

Jos Backus jos at catnook.com
Sat Dec 24 19:21:44 EST 2005


On Fri, Dec 23, 2005 at 01:55:37PM -0800, Jos Backus wrote:
[snip]
> Nitro.run(TodoController)
> 
> gives
> 
> lizzy:~/public_html/nitro/todo% ruby run.rb 
> D, [2005-12-23T13:53:58.174095 #37880] DEBUG -- : Using memory sessions.
> nil
> I, [2005-12-23T13:53:59.268807 #37880]  INFO -- : Og uses the Mysql store.
> /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/compiler/elements.rb:34:in `const_get': uninitialized constant SystemPage (NameError)
>         from /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/compiler/elements.rb:34:in `tag_start'

On Dec 14, Bryan Soto wrote:
>Using scaffolding without 'part/admin' doesn't work.
>
>The generated pages all depend on SystemPage (nitro/src/part/admin/skin.rb)
>and SystemPage depends on AdminPart (nitro/src/part/admin.rb) because of the
>inline_css setting.
>
>I'm assuming that scaffolding should be usable without part/admin. Of
>course, with gen form, maybe that's deprecated?
>
>I use Mysql so I can report on how that goes.

So I added require `'part/admin'' in hopes that that would fix that problem.

But alas, same error:

[2005-12-24 16:16:19] INFO  WEBrick 1.3.1
[2005-12-24 16:16:19] INFO  ruby 1.8.2 (2004-12-25) [i386-freebsd7]
[2005-12-24 16:16:19] INFO  WEBrick::HTTPServer#start: pid=33636 port=9999
D, [2005-12-24T16:16:34.659286 #33636] DEBUG -- : Rendering '/'.
E, [2005-12-24T16:16:34.996333 #33636] ERROR -- : Error while handling '/'.
E, [2005-12-24T16:16:34.997356 #33636] ERROR -- : No action to dispatch to on TodoController
  /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/dispatcher.rb:202:in `dispatch'
  /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/render.rb:115:in `render'
  /usr/local/lib/ruby/gems/1.8/gems/nitro-0.26.0/lib/nitro/adapter/webrick.rb:145:in `do_GET'

-- 
Jos Backus
jos at catnook.com



More information about the Nitro-general mailing list