[Nitro] BUG: nitrogen app does not create a usable CGI app on WinXP

George Moschovitis george.moschovitis at gmail.com
Thu Dec 22 03:05:40 EST 2005


> cgi.rb or run.rb file was broken, so I tried to create a bare-bones app
> using nitrogen.

As demonstrated in the videos, nitrogen is not really useful in Nitro
(as it is on Rails). You can create 1-2 dirs and start running.
However this release seems to have fixed the gem/bin path bug, and the
next release will add some features on nitro/nitrogen so you can
expect that these helpers will be heavily tested. The changes are
related to the one-step install for spark (I want to aggresively
promote spark) that I plan to do...


> No big deal for me, but some folks might wonder why these configuration
> settings don't work.  (Oh, and one more quibble: the robots.txt file is
> always empty.  Why is it there?)

thanks for pointing this out...


> The real bug is that I still get this error with CGI:
>  undefined method `is' for Nitro::Session:Class (NoMethodError)
> So, not only can't I get my existing code running under CGI, I can't get
> Nitro to generate usable CGI code.

require 'nano/module/is'

as a temp workaround.

-g.



--
http://www.gmosx.com
http://www.navel.gr
http://www.nitrohq.com




More information about the Nitro-general mailing list