[Nitro] BUG: nitrogen app does not create a usable CGI app on WinXP

TRANS transfire at gmail.com
Wed Dec 21 22:10:42 EST 2005


On 12/21/05, James Britt <james_b at neurogami.com> wrote:
> I'm still trying to run some fairly simple Nitro apps under Apache2 CGI
> on my WinXP, with no luck.
>
> I thought perhaps there was some change from 0.24 to 0.26 such that my
> cgi.rb or run.rb file was broken, so I tried to create a bare-bones app
> using nitrogen.
>
> One bug is that the apache.conf file placed in the /conf dir has
> mod_rewrite rules that set dispatch.cgi as the default script, yet there
> is no such script in /public.  Instead, there is cgi.rb and fcgi.rb
>
> No big deal for me, but some folks might wonder why these configuration
> settings don't work.  (Oh, and one more quibble: the robots.txt file is
> always empty.  Why is it there?)
>
> The real bug is that I still get this error with CGI:
>
>   undefined method `is' for Nitro::Session:Class (NoMethodError)

That's likey an alias for #include from Facets. Try adding 'require
facet/module/is', or change 'is' to 'include'.

T.




More information about the Nitro-general mailing list