[Nitro] BUG: nitrogen app does not create a usable CGI app on WinXP

James Britt james_b at neurogami.com
Wed Dec 21 21:44:14 EST 2005


I'm still trying to run some fairly simple Nitro apps under Apache2 CGI 
on my WinXP, with no luck.

I thought perhaps there was some change from 0.24 to 0.26 such that my 
cgi.rb or run.rb file was broken, so I tried to create a bare-bones app
using nitrogen.

One bug is that the apache.conf file placed in the /conf dir has 
mod_rewrite rules that set dispatch.cgi as the default script, yet there 
is no such script in /public.  Instead, there is cgi.rb and fcgi.rb

No big deal for me, but some folks might wonder why these configuration 
settings don't work.  (Oh, and one more quibble: the robots.txt file is 
always empty.  Why is it there?)

The real bug is that I still get this error with CGI:

  undefined method `is' for Nitro::Session:Class (NoMethodError)

So, not only can't I get my existing code running under CGI, I can't get 
Nitro to generate usable CGI code.


James Britt

-- 

http://www.ruby-doc.org       - Ruby Help & Documentation
http://www.artima.com/rubycs/ - Ruby Code & Style: Writers wanted
http://www.rubystuff.com      - The Ruby Store for Ruby Stuff
http://www.jamesbritt.com     - Playing with Better Toys
http://www.30secondrule.com   - Building Better Tools



More information about the Nitro-general mailing list