[Nitro] examples-0.26: blog example doesn't work

Jos Backus jos at catnook.com
Wed Dec 21 19:00:08 EST 2005


Fyi: re-runnig the blog example yields the following error:

hal% ruby run.rb
D, [2005-12-21T15:54:19.439536 #88430] DEBUG -- : Using memory sessions.
nil
I, [2005-12-21T15:54:20.341614 #88430]  INFO -- : Og uses the Mysql store.
E, [2005-12-21T15:54:20.351591 #88430] ERROR -- : Ruby-Mysql bindings are not installed!
E, [2005-12-21T15:54:20.352117 #88430] ERROR -- : Trying to use the pure-Ruby binding included in Og
D, [2005-12-21T15:54:20.480234 #88430] DEBUG -- : Og manageable classes: [Comment, Entry]
E, [2005-12-21T15:54:20.511331 #88430] ERROR -- : Og.setup had problems: NoMethodError => undefined method `[]' for nil:NilClass
E, [2005-12-21T15:54:20.511888 #88430] ERROR -- : #<NoMethodError: undefined method `[]' for nil:NilClass>
E, [2005-12-21T15:54:20.512371 #88430] ERROR -- : /usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og/vendor/mysql411.rb:250:in `unpack_fields_41'
/usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og/vendor/mysql411.rb:242:in `each'
/usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og/vendor/mysql411.rb:242:in `unpack_fields_41'
/usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og/vendor/mysql411.rb:233:in `unpack_fields'
/usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og/vendor/mysql.rb:247:in `list_fields'
/usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og/store/mysql.rb:230:in `create_table'
(eval):6:in `send'
(eval):6:in `og_create_schema'
/usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og/store/sql.rb:331:in `enchant'
/usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og/store/mysql.rb:175:in `enchant'
/usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og/manager.rb:122:in `manage'
/usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og/manager.rb:187:in `manage_classes'
/usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og/manager.rb:187:in `each'
/usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og/manager.rb:187:in `manage_classes'
/usr/local/lib/ruby/gems/1.8/gems/og-0.26.0/lib/og.rb:122:in `setup'
run.rb:15
hal% 

It works fine if I set :destroy to true.

This is with nitro 0.26 and all the latest required gems, on FreeBSD with
mysql 4.1.15 from ports.

-- 
Jos Backus
jos at catnook.com



More information about the Nitro-general mailing list