[Nitro] Og::Store (was Re: og regarding legacy apps table hints)
deb at ysabel.org
Fri Aug 19 03:40:10 EDT 2005
George Moschovitis wrote:
> I was playing a bit with the directory structure in the patch, and I
> would like to suggest
> some changes, to make this more compatible with the rest of Nitro/Og
> code. I also suggest changing the notion of 'table' into 'schema' to
> be more compatible with non-sql stores. find_options was changes to
> finder to be shorter (any ideas for a better name?).
I like both the structure and the naming changes. "finder" works for me
entirely because it implies that we're going to expand on that annoying
abstract find conditions thing. And that does seem like the right place for
it, long term, anyway.
If you get around to patches to shuffle things around, feel free to send
'em, I'll poke and incorporate. (Make sure 'rake' still passes all tests!)
If not, I'll probably shuffle/tweak names tomorrow.
I've not done anything to set up darcs auto-receive by email yet, but I may
do that too at some point here.
[ deb at ysabel.org ] - Ysabel - [ http://www.ysabel.org/ ]
More information about the Nitro-general