[Nitro] [OG] - Problems with GEM installation

Ilias Lazaridis ilias at lazaridis.com
Sun Apr 10 05:49:50 EDT 2005


Ilias Lazaridis wrote:
> http://www.rubygarden.org/index.cgi/Libraries/og_tutorial.rdoc
> 
> -
> 
> On a windows XP machine, i get this:
> 
> "
> P:\ruby\jamlang>gem install og
> 
> P:\ruby\jamlang>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install og
> Attempting local installation of 'og'
> Local gem file not found: og*.gem
> Attempting remote installation of 'og'
> Updating Gem source index for: http://gems.rubyforge.org
> ERROR:  While executing gem ... (Errno::ECONNREFUSED)
>     ─ίΊ ▐ΪάΊ ϊΫΊάΪ▐ ύ ϊύΉώΎΫ±ή▀ά ≤²Ίϊί≤ύ≥, ίΏίώϊ▐ Ύ ΫΏΎΈΎήώ≤Ϊ▐≥ 
> Ώ±ΎΎ±ώ≤ΉΎ² ΪύΊ άΏ▌±±ώ°ί ίΊί±ή▄. - connect(2)
> "
> 
> Any suggestions?

I've tried "nitro"

"
P:\ruby\navel>gem install nitro

P:\ruby\navel>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install nitro
Attempting local installation of 'nitro'
Local gem file not found: nitro*.gem
Attempting remote installation of 'nitro'
Updating Gem source index for: http://gems.rubyforge.org
Install required dependency glue? [Yn]  y
Install required dependency extensions? [Yn]  y
Install required dependency flexmock? [Yn]  y
Install required dependency og? [Yn]  y
Install required dependency ruby-breakpoint? [Yn]  y
Install required dependency extensions? [Yn]  y
Install required dependency flexmock? [Yn]  y
Successfully installed nitro, version 0.15.0
c:/ruby/lib/ruby/1.8/rdoc/parsers/parse_rb.rb:32: warning: already 
initialized constant EXPR_BEG
c:/ruby/lib/ruby/1.8/rdoc/parsers/parse_rb.rb:33: warning: already 
initialized constant EXPR_MID
c:/ruby/lib/ruby/1.8/rdoc/parsers/parse_rb.rb:34: warning: already 
initialized constant EXPR_END
c:/ruby/lib/ruby/1.8/rdoc/parsers/parse_rb.rb:35: warning: already 
initialized constant EXPR_ARG
c:/ruby/lib/ruby/1.8/rdoc/parsers/parse_rb.rb:36: warning: already 
initialized constant EXPR_FNAME
c:/ruby/lib/ruby/1.8/rdoc/parsers/parse_rb.rb:37: warning: already 
initialized constant EXPR_DOT
c:/ruby/lib/ruby/1.8/rdoc/parsers/parse_rb.rb:38: warning: already 
initialized constant EXPR_CLASS
c:/ruby/lib/ruby/1.8/rdoc/parsers/parse_rb.rb:263: warning: already 
initialized constant TokenDefinitions
c:/ruby/lib/ruby/1.8/rdoc/parsers/parse_rb.rb:268: warning: already 
initialized constant TkReading2Token
c:/ruby/lib/ruby/1.8/rdoc/parsers/parse_rb.rb:269: warning: already 
initialized constant TkSymbol2Token
ERROR:  While executing gem ... (NameError)
     uninitialized constant RubyToken::AlreadyDefinedToken
"

-

Still not sure if I got OG correctly.

-

Can I manyally download "OG" somewhere (standalone, means *not* bundled 
with nitro)?

.

-- 
http://lazaridis.com




More information about the Nitro-general mailing list