[Mongrel] cannot load such file -- 1.9/http11

Luis Lavena luislavena at gmail.com
Fri Nov 2 20:32:54 UTC 2012

On Fri, Nov 2, 2012 at 5:21 PM, Roelof Wobben <rwobben at hotmail.com> wrote:
> Hello,
> I have installed the mongrel 1.2.0-pre2 gem into my project.
> But when I do rake db:test:prepare I see this output :


You don't say what version of Ruby, Rails and OS are you using.

> cannot load such file -- 1.9/http11
> Anyone a idea how to solve this ?

While mongrel might work under Ruby 1.9, I'm not sure it will properly
work due the changes in threads. Not to mention newer versions of

I personally you move a rack-based web server, like Puma:


Which uses the same parser from Mongrel and follows a similar philosofy.

Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

More information about the Mongrel-users mailing list