[Mongrel] Mongrel service

Luis Lavena luislavena at gmail.com
Wed Sep 22 08:51:08 EDT 2010


On Wed, Sep 22, 2010 at 9:33 AM, Gerhard Koekemoer
<gerhardk at prodispace.co.za> wrote:
> Hi all

> Environment:
>
> Windows 7 64 bit
> Ruby 1.9.2.p0
> Rails 3
>
> I am getting the following error when I run the following command
> mongrel_rails service::install -N MyTestApp_4001 -p 4001 –e production:
>
> “Msvcrt-ruby18.dll is missing”
>

You're attempting to run Ruby 1.9 with a version of mongrel that
hasn't been compiled with Ruby 1.9 support.

Please install the 1.2.0 prerelease version:

gem install mongrel --pre

Also note that "mongrel_rails start" will fail with Rails 3. Which
means mongrel service will also fail. Before you report that back, see
existing issues in relation to Rails 3:

http://github.com/fauna/mongrel/issues
-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the Mongrel-users mailing list