[Mongrel] Mongrel service keeps re-starting ruby

Sebastien Perret lists at ruby-forum.com
Mon Dec 13 06:24:40 EST 2010


Hi All,

I have exactly the same problem : mongrel keeps restarting the ruby
process.
I have installed the patch_for_mongrel.rb proposed by Jonathan. I have
ruby 1.8.7 (2010-06-23 patchlevel 299) [i386-mingw32]
My version of Gem is 1.3.7. Here is the result of my command :

U:\>mongrel_rails start -e production -p 3001 -a 10.0.5.201 -l
"mongrel.log" -P "mongrel.pid" -c "D:/wamp/www/redmine" -t 0 -r "public"
-n 1024
** Starting Mongrel listening at 10.0.5.201:3001
** Starting Rails with production environment...
D:/wamp/www/redmine/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:119:Warning:
Gem::Dependency#version_requirements is deprecated and will be remo
ved on or after August 2010.  Use #requirement
d:/Ruby187/lib/ruby/1.8/yaml.rb:133:in `load': syntax error on line 74,
col 21: `    authentication: : login' (ArgumentError)
        from d:/Ruby187/lib/ruby/1.8/yaml.rb:133:in `load'
        from d:/Ruby187/lib/ruby/1.8/yaml.rb:144:in `load_file'
        from d:/Ruby187/lib/ruby/1.8/yaml.rb:143:in `open'
        from d:/Ruby187/lib/ruby/1.8/yaml.rb:143:in `load_file'
        from D:/wamp/www/redmine/config/initializers/40-email.rb:6
        from
D:/wamp/www/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:147:in
`load_without_new_constant_marking'
        from
D:/wamp/www/redmine/vendor/rails/activesupport/lib/active_support/dependencies.rb:147:in
`load'
        from
D:/wamp/www/redmine/config/../vendor/rails/railties/lib/initializer.rb:622:in
`load_application_initializers'
        from
D:/wamp/www/redmine/config/../vendor/rails/railties/lib/initializer.rb:621:in
`each'
        from
D:/wamp/www/redmine/config/../vendor/rails/railties/lib/initializer.rb:621:in
`load_application_initializers'
        from
D:/wamp/www/redmine/config/../vendor/rails/railties/lib/initializer.rb:176:in
`process'
        from
D:/wamp/www/redmine/config/../vendor/rails/railties/lib/initializer.rb:113:in
`send'
        from
D:/wamp/www/redmine/config/../vendor/rails/railties/lib/initializer.rb:113:in
`run'
        from D:/wamp/www/redmine/config/environment.rb:20
        from
d:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
        from
d:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
        from
d:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/rails.rb:147:in
`rails'
        from
d:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/mongrel_rails:113:in
`cloaker_'
        from
d:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/configurator.rb:149:in
`call'
        from
d:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/configurator.rb:149:in
`listener'
        from
d:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/mongrel_rails:99:in
`cloaker_'
        from
d:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/configurator.rb:50:in
`call'
        from
d:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/configurator.rb:50:in
`initialize'
        from
d:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/mongrel_rails:84:in
`new'
        from
d:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/mongrel_rails:84:in
`run'
        from
d:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/../lib/mongrel/command.rb:212:in
`run'
        from
d:/Ruby187/lib/ruby/gems/1.8/gems/mongrel-1.1.5-x86-mingw32/bin/mongrel_rails:281
        from d:/Ruby187/bin/mongrel_rails:19:in `load'
        from d:/Ruby187/bin/mongrel_rails:19

Any Idea ?

-- 
Posted via http://www.ruby-forum.com/.


More information about the Mongrel-users mailing list