[Mongrel] ERROR: Failed to build gem native extension.

Luis Lavena luislavena at gmail.com
Thu Dec 2 20:09:21 EST 2010

On Thu, Dec 2, 2010 at 9:48 PM, Luis Flores
<luis.fernando.flores.oviedo at gmail.com> wrote:
> Hello, I am currently not able to instal mongrel, I run a Linux Ubuntu 10.04
> system with Gems 1.3.7 when I do a "sudo gem install mongrel" I get this
> sequence of messages:


> $ sudo gem install mongrel
> gcc -I. -I/usr/local/include/ruby-1.9.1/i686-linux
> -I/usr/local/include/ruby-1.9.1/ruby/backward
> -I/usr/local/include/ruby-1.9.1 -I. -D_FILE_OFFSET_BITS=64 -fPIC -O3 -ggdb
> -Wextra -Wno-unused-parameter -Wno-parentheses -Wpointer-arith
> -Wwrite-strings -Wno-missing-field-initializers -Wno-long-long -o http11.o
> -c http11.c
> /usr/local/lib/ruby/gems/1.9.1/gems/mongrel-1.1.5/ext/http11/gem_make.out
> Would you please help me?

Mongrel 1.1.5 is not compatible with Ruby 1.9.x

You need to install the pre-release version:

gem install mongrel --pre
Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

More information about the Mongrel-users mailing list