[Mongrel] file access with mongrel running as windows service

Luis Lavena luislavena at gmail.com
Tue Aug 17 10:00:55 EDT 2010

On Tue, Aug 17, 2010 at 10:54 AM, Amit Tomar <lists at ruby-forum.com> wrote:
> David could you explain it more i think i have same sort of problem
> what i am doing is.
> i created a web application using instant rails,i having rails
> 2.2.2,mysql database,mongrel running as a server,
> i used mysql database to store the different property of files and i am
> plcing actual file(phsical file) on samba server.now i run my it as
> application ,everthing is fine but soon i run my application as windows
> service  i am getting this problem
> No such file or directory - Z:/streams/Texture.bmp
> Z: is drive letter
> here i am trying to upload Texture.bmp file to samba means to Z:/streams
> any help ..........

Unless you're running the mongrel service as the same user, the mapped
network drives are not available.

Either you use the full network path (\\SERVER\PATH) or you run the
service as the user that defines the mapped network drives.
Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

More information about the Mongrel-users mailing list