[Mongrel] file access with mongrel running as windows service

Amit Tomar lists at ruby-forum.com
Tue Aug 17 09:54:12 EDT 2010


David Vrensk wrote:
> On Nov 7, 2007 3:01 PM, gmail <neongrau at gmail.com> wrote:
> 
>> i have an archive of documents (word, excel, jpeg, png, gif...)
>> residing on a network share that is accessed via send_file.
>>
>> when running mongrel on the command line the files are properly
>> delivered.
>> with mongrel running as a service they don't.
> 
> 
> Try running "net use" inside the process to see if the network share is
> mounted at all.  This sounds like the typical Windows/web problem where 
> the
> operator assumes that everybody sees the same shares that she sees in 
> her
> session.  In reality, network shares are mounted per login session.  Two
> users can be logged in on the the same Windows server and have different
> shares available on Z:, which is clever, but also sort of confusing. 
> What
> is even more confusing is that you may be logged on as "user1" and have
> something mapped to Z:, but the service running as user1 has nothing on 
> Z: –
> it needs to create its own mappings.
> 
> Let us know if this helps.
> 
> /David

David could you explain it more i think i have same sort of problem
what i am doing is.
i created a web application using instant rails,i having rails 
2.2.2,mysql database,mongrel running as a server,
i used mysql database to store the different property of files and i am 
plcing actual file(phsical file) on samba server.now i run my it as 
application ,everthing is fine but soon i run my application as windows 
service  i am getting this problem

No such file or directory - Z:/streams/Texture.bmp
Z: is drive letter
here i am trying to upload Texture.bmp file to samba means to Z:/streams
any help ..........

-- 
Posted via http://www.ruby-forum.com/.


More information about the Mongrel-users mailing list