[Mongrel] Mongrel(_rails) crashing with rails3

Luis Lavena luislavena at gmail.com
Thu Apr 29 11:40:14 EDT 2010


On Thu, Apr 29, 2010 at 11:19 AM, Jonathan Rochkind <rochkind at jhu.edu> wrote:
> Luis Lavena wrote:
>>
>> I haven't played enough with Rails 3 to actually use mongrel with it,
>> but due the changes in rails 3 bootstrap, I would rather use rack or
>> rails server directly instead of mongrel_rails.
>>
>
> Or passenger.   I get the feeling that most developers have abandoned
> mongrel for passenger, and mongrel no longer has very many developers
> working on improving/maintaining mongrel itself either.
>

Well, I might be biased on my response.

I've been working on bring new changes to mongrel to ease the
development of it and set the ground to bring better rack integration
from Unicorn.

You can see all these changes here:

http://github.com/fauna/mongrel/commits

So is not fair to say that is abandoned.

While I use passenger in some server, I still use mongrel in more than
75% of all my production environments, even locally.

I'm cleaning up JRuby support for a new 1.2.0 release and new ones will follow.

What I have suggested about using "rails server" instead of
mongrel_rails is because mongrel_rails needs to be compatible with
previous version of Rails, and I'm not a 100% Rails user to explore
that. See this ticket:

http://github.com/fauna/mongrel/issues#issue/2

That said, if anyone work on that would happily integrate it back.

Thank you.
-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the Mongrel-users mailing list