[Mongrel] Mongrel(_rails) crashing with rails3

Luis Lavena luislavena at gmail.com
Thu Apr 29 00:03:28 EDT 2010


On Wed, Apr 28, 2010 at 10:38 PM, Doug Renn <renn at nestegg.com> wrote:
> I have this problem with a real application, but here's a simple test case
> that's failing the same way.  (using ruby 1.8.7p249)
>
> New app:
>
> $ rails rails3
>       create  ...
>
> $ cd rails3
>
> Add 'mongrel' to Gemfile
>
> $ bundle install
> Fetching source index from http://rubygems.org/
> ...
>
> $ rails server
> => Booting Mongrel
> => Rails 3.0.0.beta3 application starting in development on
> http://0.0.0.0:3000
> => Call with -d to detach
> => Ctrl-C to shutdown server
>
> Starts with mongrel.  But the following crashes:
>
> $ mongrel_rails start
> ** Starting Mongrel listening at 0.0.0.0:3000
> ** Starting Rails with development environment...
> /Volumes/Users/renn/.rvm/gems/ruby-1.8.7-p249 at rails3/gems/railties-3.0.0.beta3/lib/rails/engine.rb:122:in
> `delegate': wrong argument type Symbol (expected Proc) (TypeError)
>         from
>
>
> Not sure where to go from here.  Any help would be appreciated.
>

There are substantial changes in the way Rails 3 bootstrap that differ
considerably from what mongrel_rails is trying to perform.

The problem is that mongrel_rails needs to work with older versions of
Rails and newer too.

I haven't played enough with Rails 3 to actually use mongrel with it,
but due the changes in rails 3 bootstrap, I would rather use rack or
rails server directly instead of mongrel_rails.

-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the Mongrel-users mailing list