[Mongrel] Mongrel(_rails) crashing with rails3

Doug Renn renn at nestegg.com
Wed Apr 28 21:38:17 EDT 2010


I have this problem with a real application, but here's a simple test
case that's failing the same way.  (using ruby 1.8.7p249)

New app:

$ rails rails3
      create  ...

$ cd rails3

Add 'mongrel' to Gemfile

$ bundle install
Fetching source index from http://rubygems.org/
...

$ rails server
=> Booting Mongrel
=> Rails 3.0.0.beta3 application starting in development on
http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server

Starts with mongrel.  But the following crashes:

$ mongrel_rails start
** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment...
/Volumes/Users/renn/.rvm/gems/ruby-1.8.7-p249 at rails3/gems/railties-3.0.0.beta3/lib/rails/engine.rb:122:in
`delegate': wrong argument type Symbol (expected Proc) (TypeError)
        from
/Volumes/Users/renn/.rvm/gems/ruby-1.8.7-p249 at rails3/gems/activesupport-3.0.0.beta3/lib/active_support/core_ext/module/delegation.rb:121:in
`each'
        from
/Volumes/Users/renn/.rvm/gems/ruby-1.8.7-p249 at rails3/gems/activesupport-3.0.0.beta3/lib/active_support/core_ext/module/delegation.rb:121:in
`delegate'
        from
/Volumes/Users/renn/.rvm/gems/ruby-1.8.7-p249 at rails3/gems/railties-3.0.0.beta3/lib/rails/engine.rb:127
        from
/Volumes/Users/renn/.rvm/gems/ruby-1.8.7-p249 at rails3/gems/railties-3.0.0.beta3/lib/rails/plugin.rb:1:in
`require'
        from
/Volumes/Users/renn/.rvm/gems/ruby-1.8.7-p249 at rails3/gems/railties-3.0.0.beta3/lib/rails/plugin.rb:1
        from
/Volumes/Users/renn/.rvm/gems/ruby-1.8.7-p249 at rails3/gems/railties-3.0.0.beta3/lib/rails/application.rb:3:in
`require'
        from
/Volumes/Users/renn/.rvm/gems/ruby-1.8.7-p249 at rails3/gems/railties-3.0.0.beta3/lib/rails/application.rb:3
        from
/Volumes/Users/renn/.rvm/gems/ruby-1.8.7-p249 at rails3/gems/railties-3.0.0.beta3/lib/rails.rb:7:in
`require'
         ... 19 levels...
        from
/Volumes/Users/renn/.rvm/gems/ruby-1.8.7-p249 at rails3/gems/mongrel-1.2.0.pre2/bin/../lib/mongrel/command.rb:210:in
`run'
        from
/Volumes/Users/renn/.rvm/gems/ruby-1.8.7-p249 at rails3/gems/mongrel-1.2.0.pre2/bin/mongrel_rails:282
        from /usr/bin/mongrel_rails:19:in `load'
        from /usr/bin/mongrel_rails:19


Not sure where to go from here.  Any help would be appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/mongrel-users/attachments/20100428/04ed786e/attachment.html>


More information about the Mongrel-users mailing list