[Mongrel] Problem getting Mongrel to work with RadRails

Jason Fawcett lists at ruby-forum.com
Tue Apr 13 15:27:13 EDT 2010


Hi all,

  I'm very new to Ruby, and I'm trying to learn Ruby on Rails.  I got a
book on the subject, and I've installed everything according to the
directions, but I can't get the Mongrel server to work.  I'm using the
RadRails plugin with Aptana Studio, I've started a new project, and
everything seems to be setup fine, but whenever I try to start the
server, I get the following:

C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:156:in
`require': 126: The specified module could not be found.   -
C:/Ruby19/lib/ruby/gems/1.9.1/gems/mongrel-1.1.5-x86-mingw32/lib/http11.so
(LoadError)
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:156:in
`block in require'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:156:in
`require'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/mongrel-1.1.5-x86-mingw32/lib/mongrel.rb:12:in
`<top (required)>'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:156:in
`require'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:156:in
`block in require'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:521:in
`new_constants_in'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:156:in
`require'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rack-1.0.0/lib/rack/handler/mongrel.rb:1:in
`<top (required)>'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rack-1.0.0/lib/rack/handler.rb:17:in
`const_get'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rack-1.0.0/lib/rack/handler.rb:17:in
`block in get'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rack-1.0.0/lib/rack/handler.rb:17:in
`each'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rack-1.0.0/lib/rack/handler.rb:17:in
`get'
  from
C:/Ruby19/lib/ruby/gems/1.9.1/gems/rails-2.3.4/lib/commands/server.rb:45:in
`<top (required)>'
  from C:/Users/Jason/My Documents/Aptana Studio
Workspace/company/script/server:3:in `require'
  from C:/Users/Jason/My Documents/Aptana Studio
Workspace/company/script/server:3:in `<top (required)>'
  from -e:2:in `load'
  from -e:2:in `<main>'

I checked to make sure the file (http11.so) is located in the directory
listed above, and it is.  I've also tried upgrading rails to 2.3.5, and
I've tried re-installing mongrel with 'gem install mongrel', but I'm
still getting the exact same error.  I've googled this problem, and it
seems a lot of people have run up against it, but I couldn't find any
responses beyond 'switch to thin or passenger', which I'm not exactly
sure how to do.

Anyhow, any assistance you could render would be greatly appreciated.
-- 
Posted via http://www.ruby-forum.com/.


More information about the Mongrel-users mailing list