[Mongrel] mongrel, prefix, and latest versions of Rails?

Jonathan Rochkind rochkind at jhu.edu
Mon Nov 2 12:43:43 EST 2009


Is there a version of mongrel out yet that has a --prefix that works 
with latest versions of Rails?

When I do a "gem install mongrel", I get mongrel 1.1.5.

Using Rails 2.3.4, if I try launching mongrel with "--prefix 
/something", I get an error about:

 uninitialized constant ActionController::AbstractRequest


As this problem was first reported a year ago, I'm hoping there's a 
version of mongrel that handles it, that I just haven't managed to 
actually install with a naive "gem install mongrel", it's hiding 
somewhere else?

Or is this really not fixed in a mongrel release yet?

Any advice welcome.  (I know how to set the prefix in environment.rb 
_instead of_ mongrel command line; but I really want to do it in the 
mongrel command line sometimes).

Jonathan


More information about the Mongrel-users mailing list