[Mongrel] hi all !

hwang is lists at ruby-forum.com
Sun Mar 22 01:43:43 EDT 2009


hi all

i'm can't speak english well....

i used not rails webframework.
i used camping webframework..

i has something problem.

i used gems list is..
mongrel-1.1.5
camping-1.5.180

and update now..

camping-1.9.300

so, My blog looks like an error on the server.

my old code is ..

615 if __FILE__ == $0
616     require 'mongrel/camping'
617
618     Conf::Models::Base.establish_connection :adapter => 'sqlite3',
:database => 'conf.db'
619     Conf::Models::Base.logger = Logger.new('conf.log')
620     Conf.create
621
622     config = Mongrel::Configurator.new :host => "0.0.0.0" do
623         listener :port => 80 do
624             uri "/", :handler =>
Mongrel::Camping::CampingHandler.new(Conf)
625             uri "/favicon", :handler =>
Mongrel::Error404Handler.new("")
626             trap("INT") { stop }
627             run
628         end
629     end
630
631     puts "** http://localhost:80/"
632     t = Time.now
633     @servertime=t
634     puts "서버 시작 시간 :
#{t.year}년#{t.month}월#{t.day}일#{t.hour}시#{t.min}분#{t.sec}초"
635     config.join
636 end

and error code is,


his at info105:~$ sudo ruby conf_mongrel1.9.rb
** http://localhost:80/
서버 시작 시간 : 2009년3월22일13시30분25초
Sun Mar 22 13:30:31 +0900 2009: Read error: #<TypeError:
#<StringIO:0xb72b8c18> is not a symbol>
(eval):53:in `const_get'
(eval):53:in `method_missing'
/usr/local/lib/site_ruby/1.8/mongrel/camping.rb:53:in `process'
/usr/local/lib/site_ruby/1.8/mongrel/camping.rb:52:in `synchronize'
/usr/local/lib/site_ruby/1.8/mongrel/camping.rb:52:in `process'
/usr/local/lib/site_ruby/1.8/mongrel.rb:159:in `process_client'
/usr/local/lib/site_ruby/1.8/mongrel.rb:158:in `each'
/usr/local/lib/site_ruby/1.8/mongrel.rb:158:in `process_client'
/usr/local/lib/site_ruby/1.8/mongrel.rb:285:in `run'
/usr/local/lib/site_ruby/1.8/mongrel.rb:285:in `initialize'
/usr/local/lib/site_ruby/1.8/mongrel.rb:285:in `new'
/usr/local/lib/site_ruby/1.8/mongrel.rb:285:in `run'
/usr/local/lib/site_ruby/1.8/mongrel.rb:268:in `initialize'
/usr/local/lib/site_ruby/1.8/mongrel.rb:268:in `new'
/usr/local/lib/site_ruby/1.8/mongrel.rb:268:in `run'
/usr/local/lib/site_ruby/1.8/mongrel/configurator.rb:282:in `run'
/usr/local/lib/site_ruby/1.8/mongrel/configurator.rb:281:in `each'
/usr/local/lib/site_ruby/1.8/mongrel/configurator.rb:281:in `run'
conf_mongrel1.9.rb:627:in `cloaker_'
/usr/local/lib/site_ruby/1.8/mongrel/configurator.rb:149:in `call'
/usr/local/lib/site_ruby/1.8/mongrel/configurator.rb:149:in `listener'
conf_mongrel1.9.rb:623:in `cloaker_'
/usr/local/lib/site_ruby/1.8/mongrel/configurator.rb:50:in `call'
/usr/local/lib/site_ruby/1.8/mongrel/configurator.rb:50:in `initialize'
conf_mongrel1.9.rb:622:in `new'
conf_mongrel1.9.rb:622


plz help..
-- 
Posted via http://www.ruby-forum.com/.


More information about the Mongrel-users mailing list