[Mongrel] ERROR: Error installing mongrel:

Mahalingam Mr lists at ruby-forum.com
Mon Jun 29 02:52:04 EDT 2009


Ritesh Pareek wrote:
> Hi,
> 
> I am getting some problem while installing mongrel on GoDaddy(fedora)
> server.
> 
> Env is ::
> 
> [root at ip-97-74-86-181 bin]# gem environment
> RubyGems Environment:
>   - RUBYGEMS VERSION: 1.3.4
>   - RUBY VERSION: 1.8.6 (2008-03-03 patchlevel 114) [i386-linux]
>   - INSTALLATION DIRECTORY: /usr/lib/ruby/gems/1.8
>   - RUBY EXECUTABLE: /usr/bin/ruby
>   - EXECUTABLE DIRECTORY: /usr/bin
>   - RUBYGEMS PLATFORMS:
>     - ruby
>     - x86-linux
>   - GEM PATHS:
>      - /usr/lib/ruby/gems/1.8
>      - /root/.gem/ruby/1.8
>   - GEM CONFIGURATION:
>      - :update_sources => true
>      - :verbose => true
>      - :benchmark => false
>      - :backtrace => false
>      - :bulk_threshold => 1000
>   - REMOTE SOURCES:
>      - http://gems.rubyforge.org/
> 
> While installing mongrel i am getting ::
> 
> [root at ip-97-74-86-181 bin]# gem install mongrel
> Building native extensions.  This could take a while...
> ERROR:  Error installing mongrel:
>         ERROR: Failed to build gem native extension.
> 
> /usr/bin/ruby extconf.rb
> can't find header files for ruby.
> 
> 
> Gem files will remain installed in
> /usr/lib/ruby/gems/1.8/gems/fastthread-1.0.7 for inspection.
> Results logged to
> /usr/lib/ruby/gems/1.8/gems/fastthread-1.0.7/ext/fastthread/gem_make.out
> [root at ip-97-74-86-181 bin]#

> Please let me know where i am wrong. Thanks in advance.

> Thanks

> Ritesh PAreek

Hi,

How do you install the ruby in your server, is it by using yum or from
the source. If it is from yum, then install this package too,
ruby-devel. The ruby you installed is without header files. To install
the header files you have to install the above said package.

Rgds
TML
-- 
Posted via http://www.ruby-forum.com/.


More information about the Mongrel-users mailing list