[Mongrel] Mongrel service keeps re-starting ruby

Luis Lavena luislavena at gmail.com
Thu Jun 25 08:19:58 EDT 2009


On Thu, Jun 25, 2009 at 2:07 AM, Michael Pliskin<mike at comapping.com> wrote:
> Hi all,
>
>
>
> Some disclaimer first: I am a complete newbie in mongrel and this list, so
> please forgive me if I say something weird. I have a problem, I’ve googled
> for a solution for quite a while and failed so far, so decided to ask here.
>
>
>
> I am trying to set up my Rails application on Windows according to this
> manual:
> http://nlakkakula.wordpress.com/2008/11/24/10-steps-for-deploying-your-ruby-on-rails-application-on-a-windows-server-2008-apache-mongrel-cluster/
> . Everything is ok however when I completed all the steps, Apache complains
> that it cannot contact proxy – meaning there is something wrong with
> mongrel. I digged further and found mongrel keeping re-starting the ruby
> process. If I look into a task manager, the picture is like:
>
> -          A ruby.exe process is started
>
> -          It eats 100% CPU for 5 seconds
>
> -          It also eats about 25MB RAM
>
> -          It dies then
>
> And the process repeats forever. It looks like there is some error happening
> but I don’t know any way to capture it.
>
>
>
> My OS is Win2k Advanced Server SP4. Any ideas?
>
>
>
> Thanks,
>
>   Mike Pliskin
>

That behavior is normal with mongrel_service. has been implemented in
a way that the ruby process automatically restart in case of a
failure, which is seems is happening in the background.

To debug this, please start mongrel standalone:

cd my_app
mongrel_rails start

Doing that, you should see, on the console, what is happening.

Please paste the results on your reply so I can help you out.

Cheers,
-- 
Luis Lavena
AREA 17
-
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry


More information about the Mongrel-users mailing list