[Mongrel] Error while starting "ruby script/server"

Marcel Sadlowski lists at ruby-forum.com
Fri Feb 27 13:47:02 EST 2009


Hello,

I am very new to Ruby on Rails, but also very excited to get those
things started.
I downloaded and installed "BitNami RubyStack Stack 1.4-beta-1" which
includes all necessary tools for running RoR offline under OS X (10.5).
I tried to get it started before in some other different ways, but I
never got it, because I am very new to this.
Finally now I tried to start my rails app, but then something strange
happened.

In my web browser should http://localhost:3000 open my active rails
application, but there's only following error message:

Status: 500 Internal Server Error Content-Type: text/html
Application error (Rails)


So I tried to start the rails app over the Terminal. I changed to my
railsapp-folder and entered: "ruby script/server" which should start
Mongrel for my railsapp.

But the Terminal showed me:

=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.2.2 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:3000
Exiting
/Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel/tcphack.rb:12:in
`initialize_without_backlog': Address already in use - bind(2)
(Errno::EADDRINUSE)
        from
/Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel/tcphack.rb:12:in
`initialize'
        from
/Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel.rb:93:in `new'
        from
/Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel.rb:93:in
`initialize'
        from
/Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel/configurator.rb:139:in
`new'
        from
/Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel/configurator.rb:139:in
`listener'
        from
/Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:99:in
`cloaker_'
        from
/Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel/configurator.rb:50:in
`call'
        from
/Library/Ruby/Gems/1.8/gems/mongrel-1.1.5/lib/mongrel/configurator.rb:50:in
`initialize'
         ... 14 levels...
        from
/Library/Ruby/Gems/1.8/gems/rails-2.2.2/lib/commands/server.rb:49
        from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
        from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
`require'
        from script/server:3


It says, that the localhost-address is already in use, but I have no
idea how I can reset it.
Can somebody help me with this problem?

Greetz,
Marcel
-- 
Posted via http://www.ruby-forum.com/.


More information about the Mongrel-users mailing list