[Mongrel] [Mongrel-development] Mongrel, cross compilation, Echoe and rake-compiler

Luis Lavena luislavena at gmail.com
Sun Apr 26 21:36:52 EDT 2009

On Sun, Apr 26, 2009 at 10:12 PM, Evan Weaver <evan at cloudbur.st> wrote:
> I think that's a good plan. Echoe has some rudimentary
> cross-compilation (used for JRuby), but not for Mingw. Your way is
> better.

rake-compiler still doesn't support JRuby, but perhaps a JavaJarTask
is coming, but I'm not holding my breathe until I see these patckes

> My plan is as so:
> Gossamer + Rack launch script + some optimizations/bugfixes + Ruby 1.9
> compat = more or less Mongrel 2.0.

The work on this has already started? Gossamer is the codename?

> This puts you in a tough spot, but it's probably best to branch off
> Gossamer and let me forward-port whatever is missing. The 1.x branches
> are effectively dead, except for a Ruby 1.9 compat update (v1.1.6).

I've no problem working with bleeding edge stuff, as long I can find it :-)

> I promise to get to this every weekend, and don't, so I'll stop
> promising. I may be able to squeeze some time out of work to spend on
> it.

No rush, my only concern is ensure Mongrel itself works on the
upcoming One-Click Installer. Got all the details ironed to do a
release tonight, and when started to install in a sandbox found that
Mongrel wasn't working.

Anyhow, now I have a Mac so 3 way testing between Linux, OSX and
Windows is now possible form my side, so promise not break anything

Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

More information about the Mongrel-users mailing list